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Subject: Computer

Duration (Periods): 2

Lesson Name: The Number System

Overview: Computers rely on numerical representations to comprehend our instructions.

Prior Knowledge: The students are familiar with the number system.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

 • understand the significance of number system.

 • convert decimal to binary numbers.
 • convert binary to decimals.

 • perform arithmetic operations on binary numbers.

Teaching Aids: 
 • https://i.pinimg.com/564x/5d/60/b5/5d60b5e6463a1e58a27e62056c9806c8.jpg

 • https://i.pinimg.com/564x/0a/66/a9/0a66a9fa4e43944348bb8d14e7be4ca2.jpg

Learning Segments:

LESSON LINK
Time: 05 minutes
Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
 • The systematic depiction of numbers through digits or 

other symbols is known as the number system.
 • We can determine the value of any digit in a number by 

referring to the digit, the position of the digit and the 
base of the number system.

LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
 • Introduce the students to the categories of 

number system such as binary, octal, decimal and 
hexadecimal.

 • Explain the formation of binary numbers.
 • Demonstrate the conversion of decimal to binary and 

vice versa.
 • Explain the arithmetic operations on binary numbers.

Period 2
 • Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

 • Ensure that each student has completed the task.
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LESSON CLOSURE
Time: 05 minutes
Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

 • Discuss the answers to the questions.
 • Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 1]

A. Tick () the correct option.
1. a. 2 2. a. 16 3. b. radix 4. c. machine
5. b. LSD

B. Fill in the blanks using the words in the box.
1. radix 2. hexadecimal 3. 10 4. octal
5. MSD

C. Write T for True and F for False statements.
1. T 2. F 3. F 4. T
5. F

D. Answer the questions in a few words.
1. The number system is categorised into four types, i.e., Binary, Octal, Decimal and 

Hexadecimal.
2. In binary subtraction, the lower value of binary is subtracted from the higher value 

of binary. There are some rules to follow for binary subtraction. When the binary 
value Y is greater than the binary value X, 1 is borrowed from the next position. 
When the binary digit 0 borrows 1 from the next MSD, it becomes 10.

3. The octal number system comprises eight distinct digits ranging from 0 to 7, 
establishing its base as 8. In this number system, all digits must be less than 8.

4. The first digit on the right side of the decimal point has the lowest value and hence, 
is called the Least Significant Digit (LSD).

5. The total number of digits used in a computer system is called the base or radix 
of the number system.

6. The hexadecimal number system incorporates a total of 16 digits, 0 to 9 and A 
to F. In this system, the decimal numbers 10 to 15 are represented by the letters 
A to F.
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E. Answer the following questions.
1. In binary subtraction, the lower value of binary is subtracted from the higher value 

of binary. There are some rules to follow for binary subtraction.

X Y X - Y

0 0 0 - 0 = 0

0 1 0 - 1 = 1 (borrow 1)

1 0 1 - 0 = 1

1 1 1 - 1 = 0

1 1 1 1 1

- 1 0 1 0

1 0 1 0 1

Example:

2. The steps to convert a binary number into a decimal number are:
• Identify the LSD (rightmost) and MSD (leftmost) from the number.
• Multiply each digit of the number with 2 raised to a specific power as per the 

position.
• Add the results to get the decimal number.

3. The binary number system consists of two digits 0 and 1. A combination of these 
two digits can be used to represent any quantity. The weight of each position is a 
power of 2. Observe the following table to understand the place value of digits, 
in reference to their position and weight.

4. Conversion of binary number (101011)2 to decimal number:

= (1 × 25) + (0 × 24) + (1 × 23) + (0 × 22) + (1 × 21) + (1 × 20)
= 32 + 0 + 8 + 0 + 2 + 1
= 43

Position 3 2 1 0
.

-1 -2

Weight 23 22 21 20 2-1 2-2
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Subject: Computer

Duration (Periods): 2

Lesson Name: Excel 2016: Charts

Overview: The tables that we create in Excel, can be represented as charts.

Prior Knowledge: The students have basic knowledge of using Excel.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

 • understand the components of a chart.

 • understand the usage of various charts in Excel.

 • create a chart and change the chart type.

��� ([FHO�������&KDUWV�

5. The rules to follow for binary addition are:

X Y X + Y

0 0 0 + 0 = 0

0 1 0 + 1 = 1

1 0 1 + 0 = 1

1 1 1 + 1 = 10 (carry 1)

6. The categories of the number system are:
• The decimal number system is the most widely used method for representing 

numerical values. It comprises of ten digits, 0 to 9, and its base is 10.
• The binary number system consists of two digits, 0 and 1. A combination of these 

two digits can be used to represent any quantity. The weight of each position 
is a power of 2.

• The octal number system comprises eight distinct digits, ranging from 0 to 7. 
Its base is 8.

• The hexadecimal number system incorporates a total of 16 digits, 0 to 9 and A 
to F. In this system, the decimal numbers 10 to 15 are represented by the letter 
A to F.
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Teaching Aids: 
 • https://www.goskills.com/Excel/Resources/Excel-charts

 • https://www.youtube.com/watch?v=TfkNkrKMF5c

Learning Segments:

LESSON LINK
Time: 05 minutes
Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
 • Each chart is a visual summary of information.
 • Charts are useful for interpreting and analysing data 

trends, patterns and relationships.

LESSON EXECUTION
Time: 25 minutes
Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
 • Explain the usage of charts in Excel.
 • Point out and explain the components of chart.
 • Use placards to display the different types of charts in 

Excel.
 • Demonstrate the method to create a chart and 

change the chart type.

Period 2
 • Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

 • Ensure that each student has completed the task.

LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

 • Discuss the answers to the questions.
 • Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 2]

A. Tick () the correct option.
1. b. Home 2. c. percentage 3. b. Chart Design 4. a. Insert
5. c. chart

B. Fill in the blanks using the words in the box.
1. Line 2. Scatter 3. bars 4. Data
5. Charts

C. Write T for True and F for False statements.
1. F 2. F 3. T 4. T
5. F
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D. Answer the following questions in a few words.
1. The bar chart displays the data in the form of long bars that are plotted horizontally 

on the chart area. 
2. The data labels make a chart easier to understand because they show details about 

a data series or its individual data points.
3. The chart area includes everything, including the plot area.
4. The horizontal or vertical chart gridlines extend from any horizontal and vertical 

axes across the plot area of the chart.
5. Plot area is the area where the chart is plotted.

E. Answer the following questions. 
1. The components of a chart in Excel are:

• Chart Title: It is easier to understand a chart when we add a title to it. 
• X-axis: The horizontal axis of the chart displays text labels instead of numeric 

intervals. It is also known as category axis. 
• Y-axis: The vertical axis of the chart offers scaling options for the charts. It is 

also known as value axis. 
• Plot Area: It is the area where the chart is plotted. 
• Data Series: A data series is a row or column of numbers that are entered in a 

worksheet and plotted in your chart. 
• Data Labels: Data labels make a chart easier to understand because they show 

details about a data series or its individual data points. 
• Gridlines: Horizontal or vertical chart gridlines extend from any horizontal and 

vertical axes across the plot area of the chart. 
• Legend: It helps readers understand the charted data. Whenever you create a 

chart in Excel, a legend for the chart is automatically generated at the same time.
• Chart Area: The chart area includes everything, including the plot area. 

2. Pie charts can convert one column or row of spreadsheet data into a pie chart. Each 
slice of pie represents the size or percentage of that slice relative to the whole pie. 

 Diagram of pie chart:
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3. In Excel, the tables that we create can be represented in the form of charts. Each chart 
is a visual summary of information. Charts are useful for interpreting and analyzing 
data trends, patterns and relationships. The different types of charts in Excel are: 
Line chart, Column chart, Pie chart, Bar chart, Area chart, Scatter chart, etc.

4. The steps to create a chart in Excel are:
• Select the range of cells, for example, A1:C8.
• On the Insert tab, click on Insert Column or Bar Chart from the Charts groups.
• Select 2D Column Chart from the drop-down list.  The chart will appear in the 

Excel sheet.
5. The steps to change the chart type are:

• Select the chart that you want to change.
• Click on the Change Chart Type option from Type group, in the Chart Design tab.
• Select the chart layout from the previews on the right panel. The chart will 

change into a Bar Chart.

��� ([FHO�������$GYDQFHG�)HDWXUHV

Subject: Computer

Duration (Periods): 2

Lesson Name: Excel 2016: Advanced Features

Overview: We can sort and filter the data in Excel as per the requirement.

Prior Knowledge: The students have basic knowledge of using Excel 2016.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

 • understand the meaning of sorting and filtering.

 • filter the data.
 • apply custom filters.

 • apply conditional formatting.

Teaching Aids: 
 • https://www.youtube.com/watch?v=cEeM0U2493Q

 • https://support.microsoft.com/en-us/office/filter-data-in-a-range-or-table-01832226-
31b5-4568-8806-38c37dcc180e
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Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
 • We sort the information in a worksheet to rearrange 

the data and find specific values quickly.
 • We filter the data in Excel to show the data we want 

and hide the rest.

LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
 • Demonstrate the steps to custom sort the data or 

apply custom filter.
 • Explain the method of removing filters.
 • Explain the meaning of conditional formatting and 

the steps to apply it.

Period 2
 • Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

 • Ensure that each student has completed the task.

LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

 • Discuss the answers to the questions.
 • Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 3]

A. Tick () the correct option.
1. b. Filter 2. c. Clear 3. a. cells 4. b. New
5. c. Color scales

B. Fill in the blanks using the words in the box.
1. Custom 2. Clear Rules 3. Editing 4. Color
5. Icon

C. Write T for True and F for False statements.
1. T 2. F 3. T 4. F
5. T

D. Answer the questions in a few words.
1. We sort information in a worksheet to rearrange the data in order to find values 

quickly. We can sort a range or table of data on one or more columns of data. We 
can sort the data in ascending or descending order.
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2. A data bar helps us to see the value of a cell relative to other cells. The length of 
the data bar represents the value in the cell. A longer bar represents a higher value, 
and a shorter bar represents a lower value. 

3. Icon sets are used to annotate and classify data into three to five categories 
separated by a threshold value. Each icon represents a range of values.

4. Clear Rules options is used to remove all conditional formatting applied to a data 
range.

5. We filter the data in Excel to show the data we want and hide the rest.

E. Answer the following questions. 
1. In Excel, we apply a custom filter to derive specific values from the data as per the 

requirement. The steps to apply custom filter are:
• Apply filters to the data.
• Click on any Column arrow. A menu will appear.
• Select the Text Filters option. A sub-menu will appear.
• Select Equals option from the menu. The Custom AutoFilter dialog box will appear.
• Select the required value from the menu.
• Click on the OK button. The entries that match the criteria will be displayed.

2. The steps to sort the data in a worksheet are:
• Select a column or a range of data that is to be sorted.
• On the Home tab, click on the Sort & Filter command from the Editing group. A 

drop-down menu will appear.
• Select the Sort A to Z or Sort Z to A option to sort the data in ascending or 

descending order alphabetically.
3. The steps to remove filters from the data are:

• Click on any cell in the worksheet.
• On the Home tab, click on the Sort & Filter command in the Editing group. A 

sub-menu will appear.
• Select the Filter option from the menu.

4. The steps for filtering the data are:
• Select the range that needs to be filtered.
• On the Home tab, click on the Sort & Filter command from the Editing group.
• Select the Filter option from the drop-down menu. A small arrow will appear in 

front of the column headers.
• Click on the arrow in front of any column header, a drop-down menu will appear. 

All the entries will be visible in the list with small checkboxes. We can uncheck 
the boxes in order to hide those entries from the data.

• Click on the OK button. The rows with unchecked boxes will be removed from 
the list. 
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5. The steps to custom sort the data of various columns at the same time are:
• Select the range of columns to be sorted.
• On the Home tab, click on the Sort & Filter command from the Editing group. A 

drop-down list will appear.
• Click on the Custom Sort option from the menu. Click on the ‘My data has headers’ 

checkbox, in case the selected columns have a heading at the top.
• Click on the Sort by arrow and select the column in order to sort the data according 

to it.
• Then, click on the Sort on arrow and select the Cell values option.
• Now, click on the Order arrow and select A to Z or Z to A option.
• Click on the Add Level button on the top left corner of the dialog box to add 

another column for sorting.
• Click on the OK button.

��� $QLPDWH�&&��0RUH�7RROV

Subject: Computer

Duration (Periods): 2

Lesson Name: Animate CC: More Tools

Overview: Adobe Animate is used to design vector graphics and animation tailored for 
various digital platforms.

Prior Knowledge: The students have basic knowledge of using Adobe Animate CC.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

 • create a motion, classic and shape tween.
 • work with layers.

 • use masking and format the text in Animate CC.

Teaching Aids: 
 • https://creativecloud.adobe.com/en-IN/learn/app/animate

 • https://www.youtube.com/watch?v=0itiuHreY3A
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Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
 • The process of creating smooth transitions between 

frames is known as tweening.
 • Layers in Animate CC enable us to organise the 

artwork in our document.

LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
 • Explain the meaning of motion tween, classic tween 

and shape tween.
 • Demonstrate the steps to create motion tween, 

classic tween and shape tween.
 • Explain the meaning of masking and demonstrate the 

steps to do it.
 • Demonstrate the method to format the text in 

Animate CC.

Period 2
 • Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

 • Ensure that each student has completed the task.

LESSON CLOSURE
Time: 05 minutes
Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

 • Discuss the answers to the questions.
 • Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 4]

A. Tick () the correct option.
1. c. Oval 2. b. Layers 3. a. Masking 4. a. Adobe Inc.
5. c. Motion

B. Fill in the blanks using the words in the box.
1. Insert 2. masking 3. Classic 4. tweening
5. Layers

C. Write T for True and F for False statements.
1. T 2. F 3. T 4. F
5. F
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D. Answer the following questions in a few words.
1. A layer can be renamed by double-clicking on the existing name and typing another 

name.
2. Select File → Import → Import to Stage option to import pictures on the stage.
3. The steps to delete a layer are:

• Select the layer in the Timeline panel.
• Click on the Delete Layer button at the bottom. The selected layer will be 

deleted.
4. Click on Control → Test Movie → In Animate to view the motion tween.
5. An animation can be defined as a set of pictures put together in a sequence to 

create the illusion of movement.

E. Answer the following questions.
1. The steps to create a masking effect are:

• Create a new document in Animate CC.
• From the Tools panel, click on the Selection Tool.
• In the Timeline panel, click on Frame 100, then right-click and select the Insert 

Frame option.
• Click on Frame 1 from the Timeline panel.
• Select File → Import → Import to Stage option from the menu bar to import 

pictures to the background.
• The imported image will appear on the stage. Add a new layer.
• Select Layer 2 from the left pane of the Timeline panel.
• Click on Frame 1 in the Timeline panel.
• Select the Rectangle Tool from the Tools panel and draw a rectangle to the left 

side of the stage.
• Right-click on Frame 100 of Layer 2 from the Timeline panel.
• Select the Convert to Keyframes option.
• Click on the Selection Tool from the Tools panel.
• Select the rectangle object and drag this object to the right side of the stage.
• Right-click on the Timeline panel between Frame 1 and Frame 100 and select 

the ‘Create Shape Tween’ option.
• The Timeline colour changes to indicate that the shape tween has been created.  

Right-click on Layer 2 and select the Mask option.
• After selecting the Mask option, the mask is created. To view the mask, click on 

Control → Test Movie → In Animate option from the menu bar.  The masked 
animation will be displayed in the pop-up window.
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2. The steps to create a classic tween are:
• Create a new document in Animate CC.
• Click on the Fill Color Tool to fill the colour of your choice.
• Select the Rectangle Tool from the Tools panel.
• Draw a rectangle on the left side of the stage, using the Rectangle Tool.
• On the Timeline, click on Frame 1 on the Layer 1.
• Select Insert → Classic Tween option from the menu bar.
• Click on Frame 20 on Layer 1 of the Timeline.
• Click on Insert → Timeline → Keyframe option from the menu bar.
• Click on the Selection Tool from the Tools panel.
• Drag the rectangle to the bottom of the stage.
• On the Timeline, click on Frame 40 on Layer 1.
• Select Insert → Timeline → Keyframe option from the menu bar.
• From the Tools panel, click on the Selection Tool.
• Drag the rectangle to the right side of the stage.
• Select the Control → test Movie → In Animate option to play the movie.

3. The steps to format the text in Animate CC are:
• Click on the Text Tool from the Tools panel.
• Choose font size, color, style, etc. from the Properties panel.
• Type any text on the stage.
• Select the text using the Selection Tool.
• Click on Modify → Break Apart option from the menu bar.
• Select the individual character to change the colour.

4. The steps to create a motion tween are:
• Create a new document in Animate CC. Draw an object that you want to move 

on the Stage. Convert the object into a Movie Clip symbol.
• In the Timeline panel, click on Frame 1 of layer 1.
• Using the Selection Tool, drag the object to the left side of the stage.
• Select the Motion Tween option from the Insert menu.
• The Timeline is incremented to Frame 30 by default and the playhead shifts to 

Frame 30. 
• Select the symbol and drag it across the stage. The motion guide will indicate 

the symbol path of motion between Frame 1 and Frame 2.
• Click on Control → Test Movie → In Animate to view the motion tween. The 

motion tween animation will be displayed in a window.
• Motion guide can be used to change the direction of animation. Move the cursor 

to the anchor points in the motion guide, it will turn into arrow with a curve.
• Drag the anchor points to another position. 
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5. The steps to create a shape tween are: 
• Create a new document in Animate CC.
• Select the Oval Tool from the Tools panel and draw a circle on the stage.
• From the Tools panel, click on the Selection Tool.
• In the Timeline panel, right-click on Frame 50 and select the Insert Keyframe 

option.
• Select the circle object on the stage by using the Selection Tool.
• Press the Delete key. The circle will be removed from the stage.
• Select the Rectangle Tool from the Tools panel and draw a rectangle.
• Right-click on the Timeline panel between Frame 1 and Frame 50 and select 

the ‘Create Shape Tween’ option.
• The Timeline colour will change into purple, to indicate that the shape tween 

has been created.
• To view the Shape tween, click on the Control → Test Movie → In Animate 

option from the menu bar. The shape tween animation will be displayed in a 
pop-up window. 

��� , HUQHW�6HUYLFHV

Subject: Computer

Duration (Periods): 2

Lesson Name: Internet Services

Overview: We can establish connections and communicate with individuals worldwide, 
creating a global social network.

Prior Knowledge: The students are aware of some social networking websites such as 
Facebook, Pinterest, etc.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

 • understand the meaning of social networking.

 • identify the advantages of e-banking.

 • create an account on various social networking sites.

 • understand RSS, cloud computing, blogging and podcasting.

Teaching Aids: 
 • https://i.pinimg.com/564x/67/eb/14/67eb1448782c8652ec21b68419e68e4e.jpg

 • https://i.pinimg.com/564x/be/68/f3/be68f382d4a96505ea7c49ad5eddff78.jpg
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Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
 • Social networking involves the process of connecting 

with people using online platforms.
 • Engaging in computer-based banking operations is 

known as e-banking.

LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
 • Demonstrate the steps to create an account on 

Facebook, X, Pinterest, Blogger, OneDrive, etc.
 • Explain the meaning and benefits of e-banking.
 • Define the different modes of payment.
 • Explain the meaning of RSS and podcasting.

Period 2
 • Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

 • Ensure that each student has completed the task.

LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

 • Discuss the answers to the questions.
 • Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 5]

A. Tick () the correct option.
1. b. SkyDrive 2. c. Syndication 3. b. 280 4. b. Paytm
5. a. network

B. Fill in the blanks using the words in the box.
1. blog 2. E-Banking 3. Podcasting 4. Cloud
5. networking

C. Write T for True and F for False statements.
1. F 2. F 3. T 4. T
5. T
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D. Answer the questions in a few words.
1. The different modes of payment are:

• Debit or Credit card: We have the option to complete online purchases using 
either a debit or credit card. When using a debit card, it’s essential to ensure 
that our account contains adequate funds to cover the cost of the product or 
service. With credit cards, it’s important to stay mindful of the set credit limit, as 
purchases can only be made within that predefined limit. During the payment 
process, we are required to input the Card Verification Value (CVV) number, 
after which the bank sends a One-Time Password (OTP) to verify our identity. It’s 
crucial never to share both the CVV and OTP with anyone to maintain security.

• Net Banking: Internet banking services are typically accompanied by a Customer 
ID and PIN, which can be utilized for conducting online transactions directly from 
the associated bank account. To enhance security, an OTP (One-Time Password) 
is dispatched to the registered mobile number (RMN).

• E-Wallet: An E-wallet, also referred to as a digital wallet, serves as a means 
to facilitate online payments. To initiate transactions via the wallet, users are 
required to transfer funds from their bank accounts into it. E-wallets like Google 
Pay, Paytm, PayPal, BHIM App, PhonePe, Airtel Money, among others, represent 
some prominent Payment Service Providers (PSPs) commonly used for this 
purpose. 

2. Two social networking platforms are Facebook and Twitter.
3. The advantages of cloud computing are:

• Cost effective: Through cloud computing, we can alleviate the cost of maintaining 
computing infrastructure.

• Flexibility and speed: We can get quick access to resources from across the 
globe.

• Ease of storage: There is unlimited storage space in cloud computing, 
therefore, we can never run out of data space. Files can be easily shared with 
the co-workers.

• Data Security: We can access advanced security and reliability features of the 
data by using cloud computing. There are authentication, access control and 
encryption measures which ensure that there is no unauthorised access to critical 
data.

4. Really Simple Syndication (RSS) tracks and delivers updates whenever the sites 
previously visited by the user are refreshed. It operates as a system incorporating 
a variety of web feeds, including headlines, music videos, blog posts, etc.

5. Podcast refers to the digitally recorded audio files that are available for subscribers 
to download.
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E. Answer the following questions.
1. The steps to access OneDrive are:

• Click on the Start button.
• Click on the OneDrive app. The Microsoft OneDrive window will appear.
• Enter your email address registered with Microsoft website and click on the 

Sign In button.
• Enter the password and click on the Sign In button.
• The address of the OneDrive folder of your computer will appear. Click on the 

Next button.
2. Twitter (X) is an online social networking site that allows users to send and receive 

messages known as tweets. A tweet is restricted to 280 characters. 
 The steps to create an account on Twitter are:

• Open twitter.com in your browser.
• Click on the Sign up with Google button.
• Enter your email and password and click on Next.
• Fill in your birth date in the pop-up box that appears next.
• Choose the username and language for your account and click on Next.
• Choose at least three interests from the given categories and click on Next. 

Your account will be created.
3. The benefits of e-banking are:

• Convenience: E-banking allows users to access their accounts and conduct 
transactions 24/7, eliminating the need to visit physical bank branches. This 
convenience is especially valuable for busy individuals and businesses.

• Accessibility: E-banking services are accessible from anywhere with an internet 
connection, providing easy access to account information and transaction 
capabilities.

• Time-Saving: Online banking saves time by enabling users to quickly check 
balances, pay bills, transfer funds, and perform other financial tasks with just a 
few clicks.

• Cost-Effective: E-banking can reduce or eliminate the need for paper-based 
transactions and physical visits to banks, resulting in potential cost savings for 
both customers and banks.

• Efficiency: Transactions in e-banking are typically processed faster than traditional 
methods, such as mailing cheques. This efficiency is especially beneficial for 
businesses that need to manage cash flow effectively.

• Paperless Transactions: E-banking promotes environmentally friendly practices 
by reducing the use of paper for statements, cheques, and documents.

• Security: Most e-banking systems employ advanced security measures, including 
encryption and authentication, to protect users’ financial information and 
transactions.
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• Account Monitoring: Users can easily monitor their account activity, track 
transactions, and set up alerts for specific account events, enhancing financial 
awareness and security.

• Bill Payment: E-banking often includes bill payment services, enabling users to 
pay bills electronically, schedule recurring payments, and avoid late fees.

• Transparency: E-banking provides detailed transaction histories and electronic 
receipts, enhancing transparency and record-keeping.

4. The features of Facebook are:
• Profile and Cover Photo: Pages can have profile pictures and cover photos to 

represent their brand or identity.
• About Section: Pages can provide essential information such as contact details, 

website, business hours, and a brief description in the About section.
• Call-to-Action Button: A customizable button (e.g., Contact Us, Shop Now, Sign 

Up) can be added to encourage specific actions from visitors.
• Templates: Pages can choose from different templates tailored to their category 

(e.g., business, public figure, non-profit) to optimize their layout and features.
• Tabs: Pages can organize content using customizable tabs like Posts, About, 

Shop, Events, and more.
• Posts: Pages can share text, photos, videos, links, and other content to engage 

with their audience. Users can like, comment, and share these posts.
• Messages: Visitors can send private messages to the Page, and Page admins 

can respond to inquiries and provide support.
• Events: Pages can create and promote events with details like date, time, 

location, and RSVP options.
• Reviews and Recommendations: Users can leave reviews and recommendations 

on the Page, providing feedback and ratings.
5. The steps to create an account on Pinterest are:

• Open pinterest.com on the web browser.
• Click on the Sign up button.
• Then, click on ‘Continue with Google’ or ‘Continue with Facebook’ button.
• Fill in your email address and password.
• Fill in your age. The welcome screen will appear.
• Select gender, language and interests and click on Next. A home page 

customised to your interests will appear.
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Subject: Computer

Duration (Periods): 2

Lesson Name: Using HTML5

Overview: HTML5 forms the backbone of content structure on the World Wide Web.

Prior Knowledge: The students are familiar with the concept of websites, web pages, etc.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

 • understand the uses of HTML tags and attributes.

 • use text, background, font and margin properties.

Teaching Aids: 
 • https://www.tutorialspoint.com/html5/html5_overview.htm

 • https://www.w3schools.com/html/

Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
 • HTML is used to create web pages.
 • We can use various tags and attributes to create web 

pages.

LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
 • Explain the usage of basic tags such as <HTML>, 

<HEAD>, <BODY> and <TITLE>.
 • Demonstrate the usage of various tags to change the 

appearance of text and background. 

Period 2
 • Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

 • Ensure that each student has completed the task.

LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing  
the learning outcomes of  
the lesson.

 • Discuss the answers to the questions.
 • Recapitulate the topics discussed in the lesson.

��� 8VLQJ�+70/�
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Answer Key [Chapter 6]

A. Tick () the correct option.
1. b. paragraph 2. b. <SUB> 3. c. 6 4. a. above
5. a. text

B. Fill in the blanks using the words in the box.
1. <P> 2. H6 3. Margin 4. <BR>
5. <SUP>

C. Write T for True and F for False statements.
1. F 2. F 3. F 4. F
5. F

D. Answer the following questions in a few words.
1. The <HEAD> tag is used to define the header of the web page. The information 

that is added in the <HEAD> tag instructs the computer that the information is 
not to be displayed on the web page. It is container tag, it is used in pair with the 
</HEAD> closing tag.

2. The text-transform property specifies the transformation of the text into uppercase, 
lowercase or title case.

3. The align attribute is used to align a paragraph. We can set the paragraph to be 
aligned left, right, centre or justify.

4. Margin is the space around the text, images, or elements on a web page.
5. The value of text-decoration property is Underline, Overline or Strike-through.

E. Answer the following questions.
1. Font properties are used to change the appearance of the font on the web page. 

The font properties are:

Property Value Description

font-family Name of the font Specifies the font for the  
web page

font-size Pixel values for size, 
default font size is 16px

Specifies the font size for  
the web page

font-style Normal, bold, italic Specifies the style of the font
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2. Background properties are used to make changes to the background of the  
web page. The background properties are:

3. Text properties are used to make changes to the appearance of the text on the 
web page. The text properties are:

Property Value Description

background-color Name of the colour Specifies the background 
colour of the web page

background-image Image URL Specifies the background 
image of the web page

background-repeat
Repeat, repeat-x, repeat-y 
(where x=horizontal and 

y=vertical), no repeat

Specifies the repetition of 
the image to be used on 

the web page

Property Value Description

Color Name of the colour Specifies the text colour 
on the web page.

Text-align Left, Right, Centre, Justify Specifies the alignment 
of the text.

Text-indent Length in pixels or 
percentage

Specifies the indentation 
of the first line of the text.

Text-decoration Underline, Over line or 
Strike-through

Specifies the text e>ects 
such as underline, 

overline or strike through.

Text-transform Capitalize, Uppercase, 
Lowercase and None

Specifies the 
transformation of the 
text into uppercase, 

lowercase or title case.
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4. The <P> tag defines the beginning and end of a paragraph in the text. It serves as 
a container tag. When starting a new paragraph, we use the <P> tag, and for clarity 
and ease of identification, it is recommended to include the corresponding end 
tag </P>. The <P> tag automatically inserts a blank line between two paragraphs 
which enables the visual separation of content in the text.

5. When creating a web page, we incorporate various headings and subheadings to 
differentiate between different topics and subtopics. HTML provides different levels 
of headings, each represented by container tags with both start and end tags. In 
HTML, we can specify up to six levels of headings using H1 through H6.

 H1 represents the highest level with the largest font size, while H6 denotes the 
lowest heading/subheading level with the smallest font size. This hierarchical 
structure allows for effective presentation of content on a web page.

��� +70/���/LVWV�DQG�7DEOHV

Subject: Computer

Duration (Periods): 2

Lesson Name: HTML5: Lists and Tables

Overview: In HTML5, we use different elements to create lists and tables which enable us 
to present the information in a structured and organised way.

Prior Knowledge: The students are familiar with the basic tags to create a web page using 
HTML.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

 • create lists.

 • create tables.

Teaching Aids: 
 • https://www.w3schools.com/html/html_lists.asp

 • https://www.w3schools.com/html/html_tables.asp

Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
 • A list is an arrangement of items in a specific order.
 • A table is a structured element that displays the data 

in the form of rows and columns.
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LESSON EXECUTION
Time: 25 minutes
Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
 • Define the meaning of ordered and unordered lists.
 • Demonstrate the method of creating a lists.
 • Demonstrate the usage of different CSS properties 

with the <TABLE> tag.

Period 2
 • Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

 • Ensure that each student has completed the task.

LESSON CLOSURE
Time: 05 minutes
Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

 • Discuss the answers to the questions.
 • Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 7]

A. Tick () the correct option.
1. c. <UL> 2. a. <TR> 3. b. Padding 4. c. data
5. c. text

B. Fill in the blanks using the words in the box.
1. Width 2. COLSPAN 3. description 4. three
5. ROWSPAN

C. Write T for True and F for False statements.
1. F 2. T 3. T 4. F
5. F

D. Answer the following questions in a few words.
1. The <OL> tag has two attributes named TYPE and START.
2. The definition list is also known as the description list. It is created using the <DL> tag.
3. The border property enables us to add a border to the table.
4. The child tags of the <TABLE> tag are:

• <TR> tag is used for defining table rows.
• <TD> tag is used for defining table data.
• <CAPTION> tag is used for defining the title of the table.
• <TH> tag is used for defining table headings.

5. The <TD> tag stands for table data. We fill the data in the table cells using this tag.
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E. Answer the following questions. 
1. We use the <OL> tag to create an ordered list in HTML. An item in a list that can be 

defined by using the <LI> tag. It can be used as an empty tag as well as a container 
tag. The <OL> tag has two attributes named TYPE and START which can be used 
in the following way:
• <OL TYPE= “A”> (starts the list from A)
• <OL TYPE= “a” START= “2”> (starts the list from b)
• <OL TYPE= “1” START= “10”> (starts the list from 10)
• <OL TYPE= “I” START= “2”> (starts the list from II)
• <OL TYPE= “I” START= “4”> (starts the list from iv)

 The TYPE attributes are:

2. CSS properties are used with the <TABLE> tag to apply border, border-style, border-
spacing, width, padding, background colour and colour. Properties of CSS can be 
used with any element of HTML. We will use these properties with <TABLE> tag 
to create a table in HTML:
• Border Property enables us to add a border to the table.
• Border-style Property enables us to apply outline style of the border of the table 

such as dotted, dashed, solid, double, groove, ridge, inset, outset, none and 
hidden.

• Border-color Property enables us to apply a colour to the border.
• Border-spacing Property specifies the space between borders of adjacent cells.
• Width Property defines the width of a box or a table. We can use 100% width 

to cover the complete width of the webpage.
• Padding Property specifies the space around the data in a cell of the table.
• Background-color Property specifies the background colour in a table. 
• Color property specifies text colour in the table.

Type Numbers/Alphabets Examples

A Uppercase Letters A, B, C, D, E

a Lowercase Letters A, b, c, d, e

I Uppercase Roman 
Numbers I, II, III, IV, V

i Lowercase Roman 
Numbers i, ii, iii, iv, v

1 Numbers (default) 1, 2, 3, 4, 5
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3. The <TD> tag stands for Table Data. We fill data in the table cells using this tag. 
<TD> tag has the following attributes:
• ROWSPAN: The ROWSPAN attribute indicates the number of rows a single cell 

should occupy in a table. 
• COLSPAN: The COLSPAN attribute indicates the number of columns a single 

cell should occupy in a table. 
4. An unordered list is used when the sequence of items is not important. We use 

the <UL> tag to create an unordered list in HTML. We only use the TYPE attribute 
for <UL> tag which defines the type of bullet for the list. There are three types of 
bullets in HTML:
• Disc
 Circle
 Square

5. The COLSPAN attribute indicates the number of columns a single cell should occupy 
in a table.

��� &R GLWLRQDO�6WDWHPHQWV�LQ�3\WKRQ

Subject: Computer

Duration (Periods): 2

Lesson Name: Conditional Statements in Python

Overview: The conditional statements in Python enable us to create more complex programs.

Prior Knowledge: The students are familiar with basic programming in Python.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

 • understand the types of decision-making statements.

 • make programs using the decision-making statements.

Teaching Aids: 
 • https://www.w3schools.com/python/python_conditions.asp

 • https://www.geeksforgeeks.org/python-if-else/

Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
 • Conditional statements determine the flow of 

program execution.
 • There are four conditional statements in Python.
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LESSON EXECUTION
Time: 25 minutes
Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
 • Write the syntax of all the conditional statements on 

the board.
 • Elaborate on each type of statement by giving 

examples of different conditions.
 • Demonstrate the usage of each conditional statement 

by creating different programs.

Period 2
 • Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

 • Ensure that each student has completed the task.

LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

 • Discuss the answers to the questions.
 • Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 8]

A. Tick () the correct option.
1. a. Nested if 2. c. if…else 3. c. if…elif..else 4. c. true

B. Fill in the blanks using the words in the box.
1. if 2. true 3. Conditional 4. false

C. Write T for True and F for False statements.
1. F 2. T 3. T 4. F

D. Answer the following questions in a few words.
1. The ‘if statement’ enables the program to execute a block of code if a specified 

condition evaluates to true. If the condition is false, the program can choose to 
execute an alternative block of code or take no action at all.

2. The ‘if…else statement’ checks for a condition. The statements under the ‘if 
statement’ will only be executed if the condition evaluates to True, otherwise the 
statements following the else statement will be executed.

3. The ‘nested if statement’ contains an indented ‘if…else statement’ inside the main 
‘if…else statement’. The nested ‘if…else statement’ will only be executed when 
the first if statement is true.

4. The ‘if…elif…else’ ladder is a type of ‘if statement’. Through this statement, we 
can test multiple conditions following a top-down approach. 
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E. Answer the following questions.
1. The flowchart of the ‘if statement’ is represented as:

Body of if

Statement just below if

False

True

Test Expression

2. In Python, we use conditional statements which determine the flow of program 
execution. The following conditional statements are the decision-making statements 
in Python: 
• if statement 
• if…else statement 
• Nested if statement 
• if…elif…else ladder 

3. The if…elif…else ladder is also a type of if statement. We use this statement to 
handle multiple conditions following a top-down approach. Once the main if 
statement is evaluated to be true, the indented block after that if statement is 
executed and the rest of the ladder is avoided. If none of the conditions are true, 
then the final else statement is executed.

 Syntax of nested if statement:
LI��WHVW�H[SUHVVLRQ�����
,QGHQWHG�EORFN���
HOLI��WHVW�H[SUHVVLRQ�����
,QGHQWHG�EORFN���
HOLI��WHVW�H[SUHVVLRQ�����
,QGHQWHG�EORFN��
HOVH��
,QGHQWHG�EORFN��



'LJL9HUVH��30

4. The program to check if a number is odd, even, positive or negative is:
QXP LQW�LQSXW�³(QWHU�D�QXPEHU��³��
LI�QXP! ��
����LI�QXP��  ��
��������SULQW�QXP��³LV�HYHQ�DQG�SRVLWLYH´�
����HOVH�
��������SULQW�QXP��³LV�RGG�DQG�SRVLWLYH´�
HOVH�
����LI�QXP��  ��
��������SULQW�QXP��³LV�HYHQ�DQG�QHJDWLYH´�
����HOVH�
��������SULQW�QXP��³LV�RGG�DQG�QHJDWLYH´�

��� $SS�'HYHORSPHQW

Subject: Computer

Duration (Periods): 2

Lesson Name: App Development

Overview: Application refers to a software program designed specifically for smart devices.

Prior Knowledge: The students have used applications on any smart device.

Learning Outcomes:
At the end of the lesson, the student will be able to:

 • differentiate between Android and iOS.
 • differentiate between various apps.

 • install and develop an app.

Teaching Aids:
 • https://appinventor.mit.edu/explore/ai2/beginner-videos

 • https://www.youtube.com/watch?v=BT4YihNXiYw&list=PL7sbjUYIdF3Ux_
UrRiBaC73OrJLvLza4u
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Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
 • Each app has a specific function that can be 

performed on mobile or tablet devices.
 • Different types of apps are required for each task.

LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
 • Discuss the different categories of applications.
 • Explain the difference between Android and iOS.
 • Demonstrate the steps to install an app.
 • Discuss the usage of App Inventor and demonstrate 

the steps of developing a simple app.

Period 2
 • Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

 • Ensure that each student has completed the task.

LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

 • Discuss the answers to the questions.
 • Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 9]

A. Tick () the correct option.
1. b. iPhone 2. a. BYJU’s 3. c. Play Store 4. b. business
5. a. native

B. Fill in the blanks using the words in the box.
1. Android 2. Internet 3. Social 4. Block
5. Project

C. Write T for True and F for False statements.
1. T 2. T 3. F 4. T
5. T
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D. Answer the questions in a few words.
1. The different categories of apps are educational, lifestyle, social media, productivity 

and entertainment.
2. Block Editor is the place where we combine blocks to execute an application.
3. Two educational apps are Vedantu and Udemy.
4. LinkedIn is a social media application.
5. We can download the apps from Play Store (Android) or App Store (iOS)

E. Answer the following questions
1. Productivity apps are also known as business apps. These apps organise and 

complete complex tasks. These apps improve efficiency and user experience. 
Example: Google Drive, Todoist, ClickUp, etc.

2. The steps for installing an App are:
• Tap on the Play Store icon on the device. The home screen of Google Play Store 

will appear.
• Type the name of any app in the Search for apps and games box at the top.
• Tap on the Install button. Once the download is complete, the installation will start 

automatically. After the installation, two options will appear (Uninstall, Open).
• Click on Open to use the installed app. Or, click on Uninstall to delete the 

installed app.
3. The steps to rename a button are:

• Click on the Rename button in the Components pane.
• Type a new name for the button.
• Click on the OK button. The new name will appear in the Components pane 

but it will appear as Text for Button1 in the View pane.
4. Components pane enables us to view all the components that we use and it is 

displayed in a hierarchical view. However, the Properties pane displays the properties 
of the selected components from the View pane.

5. Hybrid apps blend elements from both native and web apps. They are developed 
using technologies like HTML and CSS, similar to web apps, but require installation 
on the device, resembling native apps. Examples of hybrid apps are Gmail, 
Instagram, Twitter (X), Netflix, etc.
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Subject: Computer

Duration (Periods): 2

Lesson Name: Artificial Intelligence for SDGs

Overview: The Sustainable Development Goals (SDGs) are a set of 17 global goals adopted 
by all United Nations Member States in 2015 as part of the 2030 Agenda for Sustainable 
Development.

Prior Knowledge: The students are familiar with the concept of sustainable development.

Learning Outcomes:
At the end of the lesson, the student will be able to:

 • understand the meaning of SDGs.

 • recognise the role of AI in achievement of SDGs.

Teaching Aids:
 • https://sdgs.un.org/goals

 • https://i.pinimg.com/564x/76/7c/d4/767cd49f32c7c796e03f55c82cd995a1.jpg

Learning Segments:

LESSON LINK
Time: 05 minutes
Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
 • Artificial Intelligence (AI) represents the capacity of 

machines to exhibit intelligence through human-like 
task performance.

 • SDG stands for Sustainable Development Goals.

LESSON EXECUTION
Time: 25 minutes
Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
 • Explain the meaning of SDGs.
 • Discuss the aims of the 17 SDGs.
 • Elaborate upon the role of AI in the achievement of 

the SDGs.

Period 2
 • Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

 • Ensure that each student has completed the task.

���� $UWLILFLDO�,QWHOOLJHQFH�IRU�6'*V�
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LESSON CLOSURE
Time: 05 minutes
Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

 • Discuss the answers to the questions.
 • Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 10]

A. Tick () the correct option.
1. c. Sustainable Development Goals 2. a. Life below water
3. b. 2030   4. c. SDG 9
5. b. SDG 11

B. Write T for True and F for False statements.
1. F 2. F 3. F 4. T
5. T

C. Answer the following questions.
1. Sustainable Development Goals (SDGs) refer to a collective framework that is aimed 

at fostering both peace and well-being for current and future generations, both on a 
global scale. The 17 SDGs encompass a pressing call to action for nations worldwide, 
regardless of their development status, through a collaborative approach. These 
objectives acknowledge that eradicating poverty and addressing other forms of 
deprivation must occur concurrently with endeavours to enhance healthcare and 
education, diminish disparities, stimulate economic progress, all while confronting 
the challenges of climate change and safeguarding our vital oceanic and woodland 
ecosystems.

2. In 2015, the United Nations Member States adopted 17 Sustainable Development 
Goals.

3. The aim of SDG 7 is ‘Affordable and Clean Energy’. It focuses on ensuring access to 
affordable, reliable, sustainable, and modern energy sources for all. It encourages 
the adoption of energy-efficient technologies and renewable energy solutions to 
reduce greenhouse gas emissions and combat climate change.

4. Some of the ways in which AI can help achieve the SDGs are: 
• Data Analysis and Prediction: AI excels in rapid and accurate data analysis, 

enabling the prediction of trends and the identification of areas necessitating 
interventions. This is vital for tracking SDG progress.

• Healthcare: AI contributes significantly to early disease detection, drug discovery, 
and treatment optimization, thereby supporting SDG 3 (Good Health and Well-
being). It also aids in the efficient management of healthcare resources.
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• Education: AI-powered educational tools personalize learning experiences, 
enhancing the accessibility of education (SDG 4 - Quality Education). Moreover, 
AI addresses the global digital divide, expanding educational opportunities.

• Agriculture: AI assists farmers in boosting crop yields and optimizing resource 
utilization, aligning with SDG 2 (Zero Hunger). Additionally, it predicts crop 
diseases and optimizes irrigation practices, promoting sustainable agriculture.

• Environmental Conservation: AI is instrumental in monitoring deforestation, 
conserving wildlife, and modeling climate change (SDG 15 - Life on Land and 
SDG 13 - Climate Action). It fosters a deeper understanding of climate issues 
and facilitates mitigation efforts.

• Energy Efficiency: AI optimizes energy consumption in buildings, industries, and 
transportation, contributing to SDG 7 (Affordable and Clean Energy). It aids in 
transitioning towards cleaner energy sources and reducing carbon emissions.

5. SDG 10 seeks to reduce inequalities within and among countries. It targets income 
inequalities, but also social inequalities related to factors such as race, gender, 
disability and age.

Worksheet 1

A. Fill in the blanks using the words in the box.
1. LSD 2. Data 3. Icon 4. base
5. Charts

B. Write T for True and F for False statements.
1. T 2. F 3. T 4. F
5. F

C. Answer the following questions
1. The steps to custom sort the data of various columns at the same time are:

• Select the range of columns to be sorted.
• On the Home tab, click on the Sort & Filter command from the Editing group. 

A drop-down list will appear.
• Click on the Custom Sort option from the menu. Click on the ‘My data has 

headers’ checkbox, in case the selected columns have a heading at the top.
• Click on the Sort by arrow and select the column in order to sort the data 

according to it.
• Then, click on the Sort on arrow and select the Cell values option.
• Now, click on the Order arrow and select A to Z or Z to A option.
• Click on the Add Level button on the top left corner of the dialog box to add 

another column for sorting.
• Click on the OK button.
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2. The steps to convert a decimal number into a binary number are:
• Divide the decimal numbers by 2 (base/radix of the number system).
• Keep a note of the quotient and remainder.
• Divide the obtained quotient by 2 and repeat step 2.
• Repeat steps 1-3 until the obtained quotient is less than 2.
• List the obtained quotient and remainders from bottom to top.

3. The binary number system consists of two digits 0 and 1. A combination of these 
two digits can be used to represent any quantity. The weight of each position is a 
power of 2. Observe the following table to understand the place value of digits, 
in reference to their position and weight.

Position 3 2 1 0
.

-1 -2

Weight 23 22 21 20 2-1 2-2

4. Pie charts can convert one column or row of spreadsheet data into a pie chart. 
Each slice of the pie chart represents the size or percentage of that slice relative 
to the whole pie.

5. Binary addition is quite the same as the addition of decimal numbers. However, 
there are some rules to follow while adding binary numbers:

X Y X + Y

0 0 0 + 0 = 0

0 1 0 + 1 = 1

1 0 1 + 0 = 1

1 1 1 + 1 = 10 (carry 1)
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Worksheet 2

A. Fill in the blanks using the words in the box.
1. tweening 2. Layers 3. Blog 4. E-Banking
5. Insert

B. Write T for True and F for False statements.
1. F 2. T 3. T 4. F
5. T

C. Answer the following questions
1. The advantages of cloud computing are:

• Cost effective: Through cloud computing, we can alleviate the cost of maintaining 
computing infrastructure.

• Flexibility and speed: We can get quick access to resources from across the 
globe.

• Ease of storage: There is unlimited storage space in cloud computing, 
therefore, we can never run out of data space. Files can be easily shared with 
the co-workers.

• Data Security: We can access advanced security and reliability features of the 
data by using cloud computing. There are authentication, access control and 
encryption measures which ensure that there is no unauthorised access to critical 
data.

2. The steps to create a masking effect are:
• Create a new document in Animate CC.
• From the Tools panel, click on the Selection Tool.
• In the Timeline panel, click on Frame 100, then right-click and select the Insert 

Frame option.
• Click on Frame 1 from the Timeline panel.
• Select File → Import → Import to Stage option from the menu bar to import 

pictures to the background.
• The imported image will appear on the stage. Add a new layer.
• Select Layer 2 from the left pane of the Timeline panel.
• Click on Frame 1 in the Timeline panel.
• Select the Rectangle Tool from the Tools panel and draw a rectangle to the left 

side of the stage.
• Right-click on Frame 100 of Layer 2 from the Timeline panel.
• Select the Convert to Keyframes option.
• Click on the Selection Tool from the Tools panel.
• Select the rectangle object and drag this object to the right side of the stage.
• Right-click on the Timeline panel between Frame 1 and Frame 100 and select 

the ‘Create Shape Tween’ option.
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• The Timeline colour changes to indicate that the shape tween has been created.  
Right-click on Layer 2 and select the Mask option.

• After selecting the Mask option, the mask is created. To view the mask, click on  
Control → Test Movie → In Animate option from the menu bar.  The masked 
animation will be displayed in the pop-up window.

3. The steps to format the text in Animate CC are:
• Click on the Text Tool from the Tools panel.
• Choose font size, color, style, etc. from the Properties panel.
• Type any text on the stage.
• Select the text using the Selection Tool.
• Click on Modify → Break Apart option from the menu bar.
• Select the individual character to change the colour.

4. The steps to create a motion tween are:
• Create a new document in Animate CC. Draw an object that you want to move 

on the Stage. Convert the object into a Movie Clip symbol.
• In the Timeline panel, click on Frame 1 of layer 1.
• Using the Selection Tool, drag the object to the left side of the stage.
• Select the Motion Tween option from the Insert menu.
• The Timeline is incremented to Frame 30 by default and the playhead shifts to 

Frame 30. 
• Select the symbol and drag it across the stage. The motion guide will indicate 

the symbol path of motion between Frame 1 and Frame 2.
• Click on Control → Test Movie → In Animate to view the motion tween. The 

motion tween animation will be displayed in a window.
• Motion guide can be used to change the direction of animation. Move the cursor 

to the anchor points in the motion guide, it will turn into arrow with a curve.
• Drag the anchor points to another position.

5. The steps to create a shape tween are: 
• Create a new document in Animate CC.
• Select the Oval Tool from the Tools panel and draw a circle on the stage.
• From the Tools panel, click on the Selection Tool.
• In the Timeline panel, right-click on Frame 50 and select the Insert Keyframe 

option.
• Select the circle object on the stage by using the Selection Tool.
• Press the Delete key. The circle will be removed from the stage.
• Select the Rectangle Tool from the Tools panel and draw a rectangle.
• Right-click on the Timeline panel between Frame 1 and Frame 50 and select 

the ‘Create Shape Tween’ option.
• The Timeline colour will change into purple, to indicate that the shape tween 

has been created.
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• To view the Shape tween, click on the Control → Test Movie → In Animate 
option from the menu bar. The shape tween animation will be displayed in a 
pop-up window.

Test Paper 1

A. Tick () the correct option.
1. b. New 2. c. 10 3. c. percentage 4. c. Syndication
5. a. Masking

B. Fill in the blanks.
1. tweening 2. Clear Rules 3. Scatter 4. Cloud
5. hexadecimal

C. Write T for True and F for False statements.
1. F 2. T 3. T 4. T
5. F

D. Answer the questions in a few words.
1. The horizontal or vertical chart lines extend from any horizontal and vertical axes 

across the plot area of the chart are known as gridlines.
2. The octal number system comprises eight distinct digits ranging from 0 to 7, 

establishing its base as 8. In this number system, all digits must be less than 8.
3. The Clear Rules option is used to remove all conditional formatting applied to a 

data range.
4. The steps to delete a layer are:

• Select the layer in the Timeline panel.
• Click on the Delete Layer button at the bottom. The selected layer will be 

deleted.
5. The different modes of payment are debit or credit card, net banking and e-wallet.

E. Answer the following questions.
1. Binary addition is quite the same as the addition of decimal numbers. However, 

there are some rules to follow while adding binary numbers:

X Y X + Y

0 0 0 + 0 = 0

0 1 0 + 1 = 1

1 0 1 + 0 = 1

1 1 1 + 1 = 10 (carry 1)
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2. The steps to create a masking effect are:
• Create a new document in Animate CC.
• From the Tools panel, click on the Selection Tool.
• In the Timeline panel, click on Frame 100, then right-click and select the Insert 

Frame option.
• Click on Frame 1 from the Timeline panel.
• Select File → Import → Import to Stage option from the menu bar to import 

pictures to the background.
• The imported image will appear on the stage. Add a new layer.
• Select Layer 2 from the left pane of the Timeline panel.
• Click on Frame 1 in the Timeline panel.
• Select the Rectangle Tool from the Tools panel and draw a rectangle to the left 

side of the stage.
• Right-click on Frame 100 of Layer 2 from the Timeline panel.
• Select the Convert to Keyframes option.
• Click on the Selection Tool from the Tools panel.
• Select the rectangle object and drag this object to the right side of the stage.
• Right-click on the Timeline panel between Frame 1 and Frame 100 and select 

the ‘Create Shape Tween’ option.
• The Timeline colour changes to indicate that the shape tween has been created.  

Right-click on Layer 2 and select the Mask option.
• After selecting the Mask option, the mask is created. To view the mask, click on  

Control → Test Movie → In Animate option from the menu bar.  The masked 
animation will be displayed in the pop-up window.

3. Cloud computing entails manipulation, configuration and remote access of 
applications over the Internet. Users can access the files and applications from any 
device with an Internet connection at their convenience. 

4. The steps to sort the data in a worksheet are:
• Select a column or a range of data that is to be sorted.
• On the Home tab, click on the Sort & Filter command from the Editing group.  

A drop-down menu will appear.
• Select the Sort A to Z or Sort Z to A option to sort the data in ascending or 

descending order alphabetically.
5. Conditional formatting can help make patterns and trends in the data more 

apparent. To use it, we create rules that determine the format of cells based on 
their values.
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Worksheet 3

A. Fill in the blanks using the words in the box.
1. description 2. H6 3. ROWSPAN 4. <BR>
5. Conditional

B. Write T for True and F for False statements.
1. T 2. T 3. F 4. F
5. F

C. Application-based questions.
1. (Subjective)
2. GHI�FKHFNBHOLJLELOLW\�DJH��LVBFLWL]HQ��

����LI�DJH�! ����DQG�LVBFLWL]HQ�
��������SULQW�³<RX�DUH�HOLJLEOH�WR�UXQ�IRU�RIILFH�´�
����HOVH�
��������SULQW�³<RX�DUH�QRW�HOLJLEOH�WR�UXQ�IRU�RIILFH�´�
DJH� �LQW�LQSXW�³(QWHU�\RXU�DJH��³��
FLWL]HQVKLS� �LQSXW�³$UH�\RX�D�FLWL]HQ"��\HV�QR���³��ORZHU��
LI�FLWL]HQVKLS�  �³\HV´�
����LVBFLWL]HQ� �7UXH
HOLI�FLWL]HQVKLS�  �³QR´�
����LVBFLWL]HQ� �)DOVH
HOVH�
����SULQW�³,QYDOLG�LQSXW��3OHDVH�HQWHU�µ\HV¶�RU�µQR¶�´�
����H[LW��
FKHFNBHOLJLELOLW\�DJH��LVBFLWL]HQ�

3. GHI�FDOFXODWHBJUDGH�VFRUH��
����LI�VFRUH�! ����
��������UHWXUQ�µ$¶
����HOLI�VFRUH�! ����
��������UHWXUQ�µ%¶
����HOLI�VFRUH�! ����
��������UHWXUQ�µ&¶
����HOLI�VFRUH�! ����
��������UHWXUQ�µ'¶
����HOVH�
��������UHWXUQ�µ)¶
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Worksheet 4

A. Fill in the blanks.
1. Block 2. year 2030 3. Project 4. Goals
5. Android

B. Write T for True and F for False statements.
1. F 2. F 3. T 4. T
5. T

C. Answer the following questions.
1. The steps to rename a button are:

• Click on the Rename button in the Components pane.
• Type a new name for the button.
• Click on the OK button. The new name will appear in the Components pane 

but it will appear as Text for Button1 in the View pane.
2. The aim of SDG 14 is to conserve and sustainably use the oceans, seas and marine 

resources for sustainable development. SDG 14 focuses on conserving and 
sustainably using oceans, seas, and marine resources. It addresses overfishing, 
marine pollution, and the preservation of marine ecosystems, which are critical for 
biodiversity and the livelihoods of coastal communities.

3. Components pane enables us to view all the components that we use and it is 
displayed in a hierarchical view. However, the Properties pane displays the properties 
of the selected components from the View pane.

4. Some of the ways in which AI can help achieve the SDGs are: 
• Data Analysis and Prediction: AI excels in rapid and accurate data analysis, 

enabling the prediction of trends and the identification of areas necessitating 
interventions. This is vital for tracking SDG progress.

• Healthcare: AI contributes significantly to early disease detection, drug discovery, 
and treatment optimization, thereby supporting SDG 3 (Good Health and Well-
being). It also aids in the efficient management of healthcare resources.

• Education: AI-powered educational tools personalize learning experiences, 
enhancing the accessibility of education (SDG 4 - Quality Education). Moreover, 
AI addresses the global digital divide, expanding educational opportunities.

• Agriculture: AI assists farmers in boosting crop yields and optimizing resource 
utilization, aligning with SDG 2 (Zero Hunger). Additionally, it predicts crop 
diseases and optimizes irrigation practices, promoting sustainable agriculture.

• Environmental Conservation: AI is instrumental in monitoring deforestation, 
conserving wildlife, and modeling climate change (SDG 15 - Life on Land and 
SDG 13 - Climate Action). It fosters a deeper understanding of climate issues 
and facilitates mitigation efforts.
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• Energy Efficiency: AI optimizes energy consumption in buildings, industries, and 
transportation, contributing to SDG 7 (Affordable and Clean Energy). It aids in 
transitioning toward cleaner energy sources and reducing carbon emissions.

5. Hybrid apps blend elements from both native and web apps. They are developed 
using technologies like HTML and CSS, similar to web apps, but require installation 
on the device, resembling native apps. Examples of hybrid apps are Gmail, 
Instagram, Twitter (X), Netflix, etc.

Test Paper 2

A. Tick () the correct option.
1. b. paragraph 2. b. Padding 3. a. text 4. a. If…else
5. a. Life below water

B. Fill in the blanks.
1. 2030 2. true 3. Padding 4. Block
5. description

C. Write T for True and F for False statements.
1. T 2. F 3. F 4. T
5. F

D. Answer the questions in a few words.
1. The text-transform property specifies the transformation of the text into uppercase, 

lowercase or title case.
2. The border property enables us to add a border to the table.
3. The ‘if…elif…else’ ladder is a type of statement. We use this statement to handle 

multiple conditions following a top-down approach.
4. We can download apps from Play Store (Android) or App Store (Mac).
5. The align attribute is used to align a paragraph. We can set the paragraph to be 

aligned left, right, centre or justify.

E. Answer the following questions.
1. The aim of SDG 7 is ‘Affordable and Clean Energy’. It focuses on ensuring access to 

affordable, reliable, sustainable, and modern energy sources for all. It encourages 
the adoption of energy-efficient technologies and renewable energy solutions to 
reduce greenhouse gas emissions and combat climate change.

2. Hybrid apps blend elements from both native and web apps. They are developed 
using technologies like HTML and CSS, similar to web apps, but require installation 
on the device, resembling native apps. Examples of hybrid apps are Gmail, 
Instagram, Twitter (X), Netflix, etc.
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 1. c. 2. a. 3. b. 4. c. 5. d. 6. d. 

 7. d. 8. c. 9. d. 10. a. 11. a. 12. d.

National Cyber Olympiad

3. The Properties pane displays the properties of the selected components from the 
view pane.

4. The aim of SDG 6 is ‘Clean Water and Sanitisation’. SDG 6 emphasises access to 
clean water and sanitation for all. It seeks to provide safe and affordable drinking 
water, improve sanitation facilities, and promote proper hygiene practices. 
Sustainable water resource management and protection of ecosystems are also 
vital components of this goal.

5. Syntax of ‘if statement’:
LI��WHVW�H[SUHVVLRQ�����
,QGHQWHG�EORFN��

 Syntax of ‘if…else statement’:
LI��WHVW�H[SUHVVLRQ�����
,QGHQWHG�EORFN��
HOVH��
,QGHQWHG�EORFN��


